If you are still using Internet Explorer, you will want to switch to a more secure, modern web browser.

While Socialive Studio requires Google Chrome, other parts of the Socialive platform are well supported in updated versions of Firefox, Safari, and Edge. Internet Explorer is not supported.

Why Socialive does not support Internet Explorer (IE)

The decision to drop IE support comes after Microsoft announced it would no longer support older versions of the browser. Other services are phasing out IE for many of the same reasons we are - security risks, development costs, compatibility issues, and the small number of people using IE.

There are many reasons we will no longer support IE, including:

  • Only about 2% of Socialive traffic comes from IE 11.
  • We are not confident that IE 11 is a secure browser. Microsoft is diverting resources to focus on Edge, and fewer developers are testing for it. More bugs or vulnerabilities are inevitable.
  • IE is slow and lacks functionality.
  • We have an ambitious schedule of upcoming features and would rather use our developer resources to improve Socialive rather than fix bugs for an outdated browser.

It is likely that IE will still be around for some time. Microsoft has promised to continue supporting and updating IE 11 as long as it still supports Windows 10. That said, Microsoft’s own cybersecurity experts said, “We’re not supporting new web standards for it and, while many sites work fine, developers by and large just aren’t testing for Internet Explorer these days.”

If you prefer to or are required to use a Microsoft browser, you can use Edge. However, you must use Chrome to access Socialive Studio. 

Did this answer your question?